Error when opening MIDI output

7 posts / 0 new
Last post
tompad
tompad's picture
Error when opening MIDI output

Hi!

I get an error when selecting mididevices in FCB-Manager - why not enough memory?
Im on Win10 and got 32Gb RAM....

Error: Cannot open MIDI output device MIDIOUT8 (Alyseum U3-88c A)
There is not enough memory available for this task.  Quit one or more applications to increase available memory, and then try again.

I have quited everything except FCB-Manager but no change in error.

Regards
Thomas

Mark van den Berg
Mark van den Berg's picture

Hi Thomas,

Opening a MIDI device in FCB Manager works as follows:
FCB Manager asks the Windows MIDI system (mmsystem) to open the MIDI device.
If mmsystem cannot do this, it returns an error code to FCB Manager, and then FCB Manager asks mmsystem for the corresponding error messsage and displays it:
So in your case FCB Manager itself has generated the line 'Error: Cannot open MIDI output device ...', but the actual error message ('There is not enough memory...') comes from mmsystem.

So the error seems to lie outside FCB Manager's responsibility.
I've only tested my MIDI applications (which all use the same MIDI device routines) on Windows 7, so theoretically there could be an incompatibility between FCB Manager and Windows 10, but this seems unlikely, given that there haven't been any similar reports concerning any of my MIDI applications.

As you mention, the problem can't be your actual RAM size. In this sense the error message is rather unhelpful: basically mmsystem just fails to open the MIDI device, then reports that it's due to a lack of memory; I've seen this many times before.
One possible reason for the error could be that the MIDI device driver (with sits between mmsystem and your actual MIDI hardware) can only be open in a single "client" (application/driver) at any moment, or at least only in a limited number of clients. (E.g. I've seen MIDI devices with a maximum of 4.)
So you should look out for other applications/drivers in which your MIDI output device is open.
For instance, make sure that "Microsoft MIDI Mapper" (at least that's what it's called in Windows 7; I don't know if it even exists any more in Windows 10) isn't enabled in FCB Manager (or anywhere else), because "behind the scenes" MIDI Mapper opens all other devices.

Other things you might try:

Does the problem only occur with MIDI output devices?
What happens when you disable all MIDI output devices in FCB Manager, and enable only one or more MIDI input devices?

Given that you have 32 GiB, I assume that your OS is 64-bit Windows 10.
But which edition (32- or 64-bit) of FCB Manager are you running?
If you've used FCB Manager's installer, this should automatically have installed the edition corresponding to your OS. (FCB Manager's About box specifies its edition.)
However, to test your problem you might try both portable editions: on 64-bit Windows both the 32-bit and the 64-bit edition should run, so you could try them both. (I very much doubt you'll find a difference, but who knows.)

You might also try my MIDI Tools application. (Again: try the 32- and 64-bit portables.)
The advantage of MIDI Tools is that it doesn't have FCB Manager's extra FCB1010 "layer", so if the error occurs in MIDI Tools as well, the problem is even more likely to be "fundamental".
If so, you might try other MIDI applications (e.g. MIDI-OX): does the error show up in them as well?

Hope this helps,
   Mark.

tompad
tompad's picture

Thanks Mark!

I will test this - Iĺl be back!

tompad
tompad's picture

Hi again! :-)

It was Firefox or something else that made the error - I closed all other applications I was running
and suddenly it all worked well! Thanks for your help and time!

By the way - any plans on supporting UnO?

Mark van den Berg
Mark van den Berg's picture

Glad you figured it out!

I'm afraid that the likelihood of FCB1010 Manager ever supporting UnO has steadily gone down over the last ten years: it's now at the "highly unlikely" stage.

   Mark.

PatMaximum
PatMaximum's picture

Greetings all.

All hell broke loose when I introduced an iConnectivity MIO 10 interface to my setup, Win7, Tascam US-144, Midisport 4x4, BCR2000, Beatstep Pro and other goodies. The solution was to use Copperlan to connect all MIO10 ins and outs to individual loopMidi pipes. From here, I hook BCManager >LoopMidiPort#  >MIO10# > Bcr2000 and vice versa and viola!

I used LoopMidi as you can name the pipes thus making it a lot easier find stuff.

In Midiox, I enable Tascam, Midisport and all relevant Loopmidi ports and do NOT enable any MIO 10 ports directly - OR ELSE I get the "..Not enough memory....blabla"

Re Beatstep pro: If anybody gets hold of it's USB midi then Arturia's Midi Control Center cannot access it. BSPro's USB Midi is not enabled in Copperlan or MidiOx. Using BsPro's Din to get its output.

Sounds simple, but took weeks to figure it out...

Cheers

 

tompad
tompad's picture

I am not sure if I understand you...

Do you mean that if I use some sort of midi software like loopMIDI betwean FCB1010 and Manager it will work??