Default checkbox is always greyed out!

7 posts / 0 new
Last post
k0mp0
k0mp0's picture
Default checkbox is always greyed out!

I can't see why the "Default" checkbox for faders and encoder values is always greyed out. I want to choose a default value for my faders so when I choose the preset they jump to the middle. I also use Snapshot (current values) so it sends the values of the preset when chosen but without a default value I can't send my DAW the 50% values for faders like I want.

Mark van den Berg
Mark van den Berg's picture

The Default checkbox is not greyed out when Type on the "Standard output" tab is None. (In this situation you may or may not want to set up a "Custom output" definition: if so, you normally check the Default checkbox and select a value for the Value knob underneath.)

However, any other value for Type causes the inclusion of a "standard output" (.easypar) statement in the encoder/fader definition, which causes the receiving BCF/BCR to automatically set an "appropriate" default value. (See sections 14.1 and 14.3 in BC MIDI Implementation.pdf for more discussion.)
So in this case the Default checkbox is irrelevant, which is why it's greyed out, and you can simply select a value for the Default parameter via the Value knob.

But I agree that the dialog box is rather confusing in this respect, so I'll see if I can make things a bit clearer: maybe I'll put the Default checkbox and the Value knob within a box labelled "Default" and then rename the checkbox to "Use" and hide it when it's irrelevant.
So thanks for bringing this up!

Mark.

k0mp0
k0mp0's picture

OK great, thank you. So now I understand that the BCR/F will set an .easypar statement that doesn't support custom default values if using a standard output, how would I set a custom output to setup an NRPN? (512 on channel 2, absolute 14 bits)

Mark van den Berg
Mark van den Berg's picture

To clarify: the .easypar statement (as used in BC Manager via "Standard output") automatically assigns a default value to the Default setting, but BC Manager sends the value in the "Value" knob (on the General tab) after the .easypar statement. So you can use "Standard output" in combination with Default; there is no need to turn to "Custom output".

One thing to remember though: a BCF fader only physically jumps to its new value (such as the Default setting upon first selection of the preset) if its .motor setting is on. So in BC Manager's fader dialog box you have to set Sync to Motor on the General tab.

Hope this helps,
Mark.

k0mp0
k0mp0's picture

Seems wrong to me that it requires a custom output. I'm sure I used to custom edit the BCL scripts and my easypar statements would contain a default figure now I recall dealing with BCL. Can you maybe double check this?

Mark van den Berg
Mark van den Berg's picture

See my reply to your previous message.

k0mp0
k0mp0's picture

Brilliant! That works fine, thanks!