Can't see any of the virtual Mackie Control displays

8 posts / 0 new
Last post
garubi
garubi's picture
Can't see any of the virtual Mackie Control displays

Hallo, my name is Stefano.

First of all, thank you for your effort in making B-Control such a great piece of software. It's really powerful, and being a developer myself I understand the amount of work you put in it. Thank you again!

At the moment I'm unable to display any of the 4 virtual Mackie Display on my PC.

The PC is a laptop, equipped with 1 external monitor, running Windows XP SP3, running the latest version of B-Control.

I tried all that I can imagine to display the virtual display but nothing shows up. I deleted the ini files I found arond, uninstalled and reinstalle the B-Control. Deactivated the second monitor, but nothing... I can't see the display anywere.

Just for reference, some years ago, when I got the BCR2000, I tried the B-Control for a few days and I was able to use the Virtual Mackie display exactly on this same system.

Can you point me to some tips or debug step?

Thank you!

p.s.

Your software really deserve some donation... I'll talk to Santa Klaus and see if we can arrange something.. ;-)

Mark van den Berg
Mark van den Berg's picture

Hi Stefano,

I've just tested BC Manager in a virtual machine running Windows XP SP3 and encountered no problems with the Mackie monitors.
So your problem is probably not related to your OS.

The settings of the Mackie monitors are in BC Manager's current ".stp" file, typically "BCMan.stp". (In the installed edition of BC Manager on Windows XP, this file is in "C:\Documents and Settings\UserName\Application Data\Mountain Utilities\BC Manager".)
So you could open this stp file in a text editor (Notepad or whatever) and try to figure out what's wrong.
For instance, the first monitor has parameters starting with "MackieMonitor1".

One thing that could be wrong is that the stored screen coordinates of the Mackie monitors are off-screen. (Or in your case "off-screens" smiley)
To fix this, you could change the offending values in the stp file manually. (Make sure BC Manager isn't running at this point!)
But it's probably easier to correct these coordinates from BC Manager itself:
"Open" a Mackie monitor (from the main window: View -> MIDI -> Mackie monitors -> 1/2/3/4).
Assuming you still don't see the Mackie monitor, go to the Window list (via View -> Window list).
The Mackie monitor you've just "opened" should be listed.
Then execute "Make all windows fully visible": this should change the Mackie monitor's coordinates so that it becomes visible.

If this still doesn't help:
Open the Options dialog box of a Mackie monitor via Options -> Mackie monitors -> 1/2/3/4.
Set "Caption" to "Normal".
Make sure Foreground and Background are "sensible" colors.
Make sure "Transparent" is not enabled. (If it is enabled, "Opacity" shouldn't be too low, or the monitor will indeed be invisible.)

Another problem might be that the Mackie monitors are hidden behind some other window(s).
By default the Mackie monitors are in the exact center of the screen, but so do most other windows in BC Manager.
So try moving/closing any other windows.
It might help to set "Stay on top" of the Mackie monitors to true.

Hope this helps,
   Mark.

garubi
garubi's picture

Hi Mark,
thank you for the fast answer.

I tried your suggested action, and after some tweaking I once got Monitor 1 visible. But after I closed it I never been able to re-activate it.
 

I'll summarize what I've done, maybe there I some synthom that I can't understand" that is important

One thing that could be wrong is that the stored screen coordinates of the Mackie monitors are off-screen. (Or in your case "off-screens" smiley)
To fix this, you could change the offending values in the stp file manually. (Make sure BC Manager isn't running at this point!)

I changed the coordinates of monitor 1 to various, different position with no luck

So I went with your second suggestion:

But it's probably easier to correct these coordinates from BC Manager itself: (...) Assuming you still don't see the Mackie monitor, go to the Window list (via View -> Window list).
The Mackie monitor you've just "opened" should be listed.

Weel, no, the mackie monitor isn't in the list of "opened" windows. (I tried with all the 4 monitor, no one will be shown here)

 

So I  closed the BC Manager and come back to the .stp file.

I changed MackieMonitor1WindowVisible=0 to MackieMonitor1WindowVisible=1, saved, closed the file anc reopened the BC Manager.

Wow!! Now the Monitor 1 is well visible! Both on the sreen and in the Windows list (obviously).

So I went ahead with the test: I closed the Monitor 1 window, then reopened it: bum! nothing shows again, nor on the screen, nor in the windows list.

I reopened the .stp file and I can see that MackieMonitor1WindowVisible is come back to 0.

 

Se I'm assuming that BC Manager has no problem to write to the .stp file (since it reverted MackieMonitor1WindowVisible to 0) but can't change MackieMonitor1WindowVisible from 0 to 1

 

I tried to completly delete the .stp file and let BC Manager to create a new one. Then I repeated the whole test but it replicate the same problem.

 

I have to add that when the BC Manager starts I get 3 error windows stating:

1. Incorrect Item in file: BcPrintPosition=2,5,5

2. BcPrintZoom=0,5

3. MonitorPixelPitch=264,58333333333344

Btw: there is no printers connected or installed on this laptop.

The former 3 errors doesn't show up when I delete the .stp file and let Bc Manager recreate a new one, but as soon I relaunch the Bc Manager (i.e. from the second time) they are there.

 

Sorry for the very long post...

Is there something in what I tested that suggest to you where the problem might be?

You can see my BCMan.stp here https://pastebin.com/yQ1XybEd

 

Thank you

Stefano

Mark van den Berg
Mark van den Berg's picture

the mackie monitor isn't in the list of "opened" windows. (I tried with all the 4 monitor, no one will be shown here)

You have to perform View -> MIDI -> Mackie monitors -> 1/2/3/4 to make a Mackie monitor visible.
After this the Mackie monitor should always be listed in the "Window list".
If it isn't, I have no idea what's going wrong:
I can't reproduce your problem, not even with your stp file.
I can't see how having multiple monitors could be the cause.
It might be some weird problem related to a limitation of Windows XP (although as I wrote I can't reproduce this in my Windows XP virtual machine): perhaps BC Manager exceeds the number of screen resources or so? (But then I don't understand how you could have had "partial" success in making Mackie monitors visible.)
Does the problem only occur with the four Mackie monitors, or also with other windows, such as "MIDI input meters", "MIDI keyboard" etc.?

I'm assuming that BC Manager has no problem to write to the .stp file (since it reverted MackieMonitor1WindowVisible to 0) but can't change MackieMonitor1WindowVisible from 0 to 1

BC Manager only writes to the stp file upon termination of BC Manager. (Or  when you perform File -> Setup -> "Save As ...".)
And BC Manager only reads the stp file when BC Manager is started. (Or when you perform File -> Setup -> "Open and restart".)
So I think the stp file can't be the problem.

I have to add that when the BC Manager starts I get 3 error windows

Thanks very much for pointing this out!
This turned out to be a bug in BC Manager: the idea is that BC Manager always uses a dot as the decimal separator, but instead it used the decimal separator defined for the user's operating system (cf. "Control Panel" -> "Regional and Language Options").
In your case the operating system's decimal separator must be a comma: this explains why for instance the intended "BcPrintPosition=2.5,5" (so "2.5" + comma + "5") was wrongly written as "BcPrintPosition=2,5,5" (so with a comma after the 2), which then caused the (correct) notification upon the next start of BC Manager that this was invalid.

I've created a test build that should fix this "comma problem":
https://mountainutilities.eu/dl/BCMan-4.0.1a1-x86.zip
You can choose how to test the included BCMan-4.0.1a1-x86.exe:

  • Put it in a separate (new) folder and run it directly from there. (You don't even need to rename it.)
  • Have it replace your existing BCMan.exe (typically in "C:\Program Files\Mountain Utilities\BC Manager").

For further testing of your Mackie monitor problem, the "separate folder" solution seems best: the program will then create its stp file in that same folder, which makes comparison with your existing installation very easy.

I think the "comma problem" has nothing to do with your Mackie monitor problem, but who knows.
Some other things you might try:
Does BC Manager 3.1.0 (which you can download from here) give you the same problem?
And MIDI Tools?

Good luck!
   Mark.

garubi
garubi's picture

Mark,

Thank you!

I'll test the new release as soon as possible, I hope later today or tomorrow, then I'll let you know if the "decimal separator" bug is solved.

For the Mackie Monitor problem, I'll tray the previous version and MIDI tools too, and report here.

Stefano

garubi
garubi's picture

Hi Mark,

first of all, I tested the "test build" and indeed it doeas solve the "decimal separator problem".

Regarding the Makie monitor problem, on the other hand,I haven't be able to solve it.

  • tested with your new "alpha" build,nothng is shown
  • tested with the previous BC Manager 3.1.0 version. Nothing is shown.
  • testd with latest MIDI Tools. The firs time I ran it, it displayed the Mackie Monitor. But then I closed the Mackie Monitor windows and never been able to display it.

Since I'm using a severely stripped down version of Windows XP, optimized for audio and DAW PC, I also tested with a new "stripped down XP" installation on a virtual machine on another PC. I had the same results: no Mackie Monitor either on the "new" machine.

So I think the problem relies on my "stripped down" XP: probably it's missing some library or other...even if the fact that "sometimes" I can get the Mackie Monitors working is a bit discorcentring...

I'll keep on testing and report if I find some hother hint...

Thank you.

Stefano.

p.s.

I you want I can put someware the "stripped down" iso XP to download for you to test. It's perfecly legal, you must have a valid registration code for XP for install it.

 

Mark van den Berg
Mark van den Berg's picture

Thanks for confirming that BC Manager 4.0.1a1 fixes the decimal separator problem.
I'll think about publishing a 4.0.1 release version soon.

One reason I suggested testing BC Manager 3.1.0 and MIDI Tools was that BC Manager >=4.0.0 is created by a new compiler, which might have introduced the problem for you.
However, as you see no difference, this cannot be the problem.

So yes, it seems very possible that your stripped-down XP is the cause of the problem.
Here is a dump of the dll panel of (Sysinternals') Process Explorer for BC Manager 4.0.1 a1 running in my XP SP3 virtual machine:
https://mountainutilities.eu/dl/BCMan-dll-XP.txt
I'm not an expert on Windows dll's, so I can't pinpoint the one(s) most likely to be related to your problem.
But you might simply compare this list with the list in your stripped-down XP: any dll not shown in your list or having a different time stamp might be the culprit.
By the way, Dependency Walker seems another interesting tool for getting to the bottom of this problem.

Hope this helps,
   Mark.

Mark van den Berg
Mark van den Berg's picture

I'll think about publishing a 4.0.1 release version soon.

Done now!