BCF2000 behavior and detection between computers

5 posts / 0 new
Last post
JamesARoberson
JamesARoberson's picture
BCF2000 behavior and detection between computers

Hi there! 

I've just gotten my BCF2000 set up successfully on my new M1 MacPro where BC Manager detects it correctly and all appears to be well (faders send and receive information, etc.).  I am using it in Baby HUI Mode.  

I am trying to do the same setup on my M1 MacBook Pro and it is not detected properly (Personality is listed as Offline, etc.).

What's interesting is that I have TWO BCF2000's and BOTH work perfectly on my MacPro but neither of them fully work on my MacBook Pro (the BCF2000 only sends MIDI but doesn't receive MIDI information back/motorized faders don't move, etc).  They both have identical firmware and, like I said, both work perfectly on my MacPro and both don't fully work on my MacBook Pro.  This leads me to believe that there's something on the computer side that is inconsistent.  

What steps would you recommend to diagnose this problem on my MacBook Pro, or is there a way to export any relevant preferences and settings from my MacPro (that is working correctly) onto my MacBook Pro (that isn't)?  

Thank you!

JamesARoberson
JamesARoberson's picture

The only difference I've seen on the BCF2000 screen is that, when it's working at my studio, it says "PL" on the screen

Mark van den Berg
Mark van den Berg's picture

You're not the first person to report problems concerning my applications on ARM-based Macs.
Since I don't have access to an ARM-based Mac, I can't offer any concrete help, let alone develop ARM editions of my applications.
However, in the following topic (in the R-8 forum) I provide a few tips that might help you pinpoint the problem:
https://mountainutilities.eu/forums/any-possibility-get-use-r8-editor-macos-help
 

JamesARoberson
JamesARoberson's picture

Thank you! I'll check it out! 

JamesARoberson
JamesARoberson's picture

Hi there!  Still trying to get this to work in both directions, and extremely grateful for any insight :)

A quick synopsis:  

-Cubase and Pro Tools is receiving MIDI signal from my BCF2000 in BHUI mode. I am able to move faders in each DAW with the BCF2000.

-However, neither are sending signal to the BCF2000 when I move a fader or panning knob and Pro Tools is giving the "Pro Tools is unable to communicate with HUI" alert.  

-BC Manager detects my BCF2000 (and shows ABSENT if it is removed, and receives MIDI in the midi monitor, although it shows no output meter) but the personality is Offline and Firmware column is blank. BCF2000 shows proper 1.10 firmware on startup.

-BC Manager sees BCF2000 in MIDI Devices and it is properly assigned as the input and output in MIDI Options (with a Device ID of 1, matching my BCF2000's device ID setting)

-"Refresh connection status" and "Detect B-Controls" yields nothing although, as I've said, BC Manager detects whether the BFC2000 is plugged in or not.  

I have tried swapping USB Cables and also, as I mentioned above, I have every reason to believe that it's purely on the computer (Mac OS X) as opposed to the BCF2000 because I have a studio setup and a home setup (both with BCF2000's).  The studio one (Mac Studio 1) is working just fine regardless of which of my BCF2000s are plugged into it while the home setup (MacBook Pro M1) is exhibiting the behavior I described above.

Any help or troubleshooting tips are greatly appreciated!

Thank you!