B- Control and BCR/ BCF Connection Diffculties

9 posts / 0 new
Last post
orcordova's picture
B- Control and BCR/ BCF Connection Diffculties

Hello, my name is Oscar Cordova.

I am very grateful to have come across this software package from you as Behringer's support is useless on this situation. I downloaded the software and installed on a Mac and a PC on Windows 7Pro (64 Bit). I read through the manual with instructions for Windows drivers and installed recommended versions. I think I am following all the steps correctly to connect to a BCR2000 but still can't get to unit to get online. I assigned the correct MIDI device in the options, deselect devices not needed and still can't connect. I tried the BCR in USB and Stand-alone mode with a USB to MIDI interface with the same results.

When I click on "Refresh Connection Status" in the software I get the pop-up window with a status bar, it crawls to 100% and displays "No Response from B-Control". The software displays "offline", yet when I turn encoders on the BCR unit the MIDI Input Meters show activity in CH 1. These results are the same in PC and in Mac.

Is there a step that I might be missing here? I read through the manual a few times and can't seem to figure out if I am skipping a step. On the Mac side, Audio MIDI Setup shows the Generic USB interface when in Standalone, and the BCR when in USB mode. When in Windows, the BCR shows up under "Sound & Video Game Controllers" when in USB mode.

I'd really like to be able to make this work on my newer computers, Ihave been keeping around an old Lennovo Laptop with XP on it exclusively to program the units with the Behringer software but it recently had the\screen burn out so I can't use it anymore.

I appreciate your help ahead of time.

Mark van den Berg
Mark van den Berg's picture

Try this (personally I'd use Windows, but I can't immediately think of a reason why it shouldn't work the same in OS X):

  1. With BC Manager not running, connect the BCR directly to a USB2 port on the computer via its USB cable.
  2. Switch the BCR on.
  3. Prress EDIT + STORE: the display should say "EG". Then press encoder 1: if the display does not say "u-1", turn encoder 1 counter-clockwise until it does. Finally press EXIT. The green LED below "USB MODE" should automatically switch on.
  4. Start BC Manager.
  5. From the main window's File pull-down menu, execute "Restart with default setup". Answer Yes to the question "Do you want to restart ..."
  6. BC Manager should restart. Answer Yes to the question "Do you want BC Manager to detect your connected B-Controls now?"
  7. A window called "Detect B-Controls" should pop up, and after a second or two your BCR should be detected ("B-Controls detected: 1"). Press OK.
  8. The B-Controls window should list your BCR2000, with the Personality column saying "B-Control".

If the above doesn't work:
You write that you do receive input from the BCR when you turn encoders. However, BC Manager needs a bidirectional connection, so you may want to verify that these encoders also respond when you send data to them (e.g. from BC Manager's "(MIDI) Controllers" window.

Hope this helps,

crony (not verified)
Anonymous's picture

That defenetly helped ! Thanks !

Sfeliz's picture

Hi, I'm Niccolò and I've just found this old post.

I'm on macos catalina and I can't see my bcr2000 connected anywhere (ableton, bc manager, studio midi app on mac). I'm in usb mode (U-1) but i really don't know what i got to do. Just tried to change usb port, change 'u' mode but nothing happens. I've tried this post's solution too but nothing. 



Mark van den Berg
Mark van den Berg's picture

Just tried to change usb port, change 'u' mode but nothing happens.

When you use the USB cable to connect the BCR to your computer, you should just keep the operating mode at U-1 (at least while testing this problem): if U-1 doesn't work in this situation, nothing will. And switching a BCR to a different operating mode while a MIDI application is running on the computer can create problems itself.

Most importantly, you should try to determine whether the problem is hardware or software related.
Things to check/try:

  • Is the top right LED (labeled "USB MODE") on the BCR on when the BCR is in U-1 mode and connected to the running computer?
  • Does the MIDI device window of macOS mention the MIDI I/O devices related to the BCR? (And if so, do applications like BC Manager mention these devices?)
  • Do things work in Windows?

If things do work in Windows, the problem is probably related to the USB-to-MIDI driver in macOS.
If the answer to all the above questions is no, there is probably a hardware problem, most likely a defect in the USB controller of your BCR. (This is not unheard of. In fact I myself had such a BCR.) Or the USB cable could be defective, though I've never heard that before.

Hope this helps,

Sfeliz's picture

Hi Mark, thanks for your reply. 

1) When I selected the u mode first two or tree times the usb mode led just blinking. Than, maybe the third time it is on but i can't see it anyway on my imac.

2) Nope, I can't see nothing about my bcr2000 on my mac. I'm on macos catalina and I've tried on an older macos sistem too (mojave). It could be a compatibily problem between usb port? older vs new? is there any solution in this case?

3) unfortunately i don't have windows, I'll try with a friend of mine... 

stefanovic's picture

Hi, I have a similar behavior on my macbook pro with Mojave.

The BCR is perfectly working on Linux though, it's recognized as usb midi. So I guess this has something to do with MacOS. The usb mode light does not light up when usb is pluged in the computer, as opposed to the raspberry pi...

stefanovic's picture

ok, I tried another USB cable, and it works now.

So Sfeilz you should try with another cable. The former one I used was kind of loose at the end connected to the computer, I do not know if it's related...

Sfeliz's picture

Hi Stefanovich! 

I've just tried all my usb cables... unforntunately nothing happens. The usb led just blinks once when i connected the cable and after a couple of times that i change the mode it lights on... but nothing happens.