2 BCR2000s - one not recognised

16 posts / 0 new
Last post
clayc
clayc's picture
2 BCR2000s - one not recognised

Hi

i am using two BCR2000s to control ableton live.  Im using BC manager to try and troubleshoot my 2nd BCR which is not working as expected.

I have one BCR working perfectly with BC manager but the other one is not receiving midi via USB and wont be recognised by BC manager via USB.  Ive recently bought the 2nd BCR and Im wondering if its buggy.

Ive tried different device ids.  Ive gotten the 2nd BCR to work once with BC manager but then the next day it didnt work.  Im also noticing that with the 2nd BCR, when i go into global setup, it doesnt always work. it sometimes doesnt show EG.

I can get the 2nd BCR to send and receive midi via the midi ports with ableton live but the USB is not playing nice.

BC Manager is receiving midi from the 2nd BCR (i can see it in the midi monitor) but i cant get BC manager to recognise it and see the firware version etc.

can anyone offer advice how i can troubleshoot this?  need to check the USB and midi input somehow

clayc
clayc's picture

sorry forgot to mention, ive also tried all the usb modes 1-4.  thats how i noticed that sometimes the EG doesnt show up when trying to go into global setup mode.

Mark van den Berg
Mark van den Berg's picture

Some random observations and questions:

It could either be a hardware or a sofware problem. Over the years, several people (including me!) have encountered BCF/BCRs with defective USB controllers. If it turns out that that's what you're dealing with, you'll have to replace your BCR - or only use it in its standard ("S") MIDI modes. But it could also be a matter of configuration, either the BCR itself or something on the computer: BC Manager, Live, or even the operating system (in particular: the BCR driver).

You say "BC Manager is receiving midi from the 2nd BCR (i can see it in the midi monitor)".
Is that in a USB mode? If so, the problem might still be that the USB controller "stutters" (that's what was wrong with my first BCR), but it's more likely to be a software problem.

Most importantly, the BCR's input and output devices in the MIDI devices dialog (accessible via the main window's Options pull-down menu) should be enabled. Then performing MIDI -> "Detect B-Controls" from the B-Controls window should be able to find the BCR.

What exactly do the columns in BC Manager's "B-Controls" window say for your dodgy BCR?

While BC Manager is running, you should not change the operating mode or device ID of a BCR connected via USB, because this will make the existing USB-based MIDI I/O devices being maintained by BC Manager dysfunctional. (At least on Windows; I'm not sure about macOS.)

During testing: when you're using USB, stick to mode U-1. The other U modes only confuse things by their extra I/O devices.

Have you tried making your dodgy BCR "impersonate" your good BCR?
For instance, set up your good BCR with BC Manager correctly, exit BC Manager, switch off the good BCR and disconnect its USB cable from the computer, connect the dodgy BCR (using the same operating mode and device ID) to the same USB port via the same cable, switch on the dodgy BCR, then restart BC Manager and see if there's any difference in connection status etc.

I don't know what to think about your problem entering EG mode. Either a button has a hardware problem, or it's simply that the function keys have been disabled in the current preset.
Note that you can power on a BCR with a "clean" preset by holding STORE + EXIT while pressing the POWER button at the back. (See section 22 of BC MIDI Implementation.pdf. The list of functions in section 23 might also be useful.)

The BCR performs a firmware check (using a checksum) during startup. The display briefly shows the firmware version (typically "1.10") only if the firmware is fully OK.
So if you see "1.10", it would be utterly pointless to re-flash the firmware. (Somehow that's what a lot of people in situations like this try to do out of desperation. Just don't!)

Hope this helps,
   Mark.

clayc
clayc's picture

Hi Mark

thanks so much for your response on this.  Ive been doing so much trouble shooting i think im going around in circles.  I have been reading all the BCR manuals and the BC Manager manuals in detail.  I will try out all your suggestions.  With your note about the preset being the issue for the global setup, yes i thought that too.  So when i actually got my dodgy BCR to work that one time with BC manager, i completely wiped all the presets on th BCR and used BC manager to install the Behringer 'Only Controllers' preset across all 32 presets.  Worked fine after that both sending and receiving midi via usb but when i shut everything down and started up again, it all stopped working.  

Will report back if i have any luck as it may help others with the same issue in the future.

clayc
clayc's picture

BCR test 1

On MacBook Pro

BCR1 (good) into USB port 1 of Mac - firmware 1.07
BCR2 (dodgy) into USB port 2 of Mac - firmware 1.10

Started up both BCRs as per your instruction for clean preset

Both BCRs in U1 mode

In audio midi setup on Mac - 
BCR1 shows up on bcr2000 port
BCR2 shows up on bcr2000fx  port

In BC Manager midi devices - all ports are enabled

Midi options for BCR 1 - selected BCR2000 port  and device id is correct (3) - it connects to BC manager fine and shows the firmware number

Midi options for BCR2 - selected BCR2000fx port and device id is correct (2) - it does not connect to BC manager

BCR test 2

I try to impersonate BCR1 with BCR2.
I use the same midi cable and change BCR2 id to 3
BCR 2 still does not connect to BC manager

But if I move from the clean preset to P2 and move a knob, midi input on port 1 shows activity on channel 1

So as mentioned previously midi is sent via USB but midi receive via USB is flakey.  I have gotten it to work once but I don’t really know how.
 

clayc
clayc's picture

BCR test 3 - midi cables

Connected BCR2 up with midi cables in and out to.a midi interface

Enabled the midi inputs and outputs via devices in BC manager

Changed id to 1
Changed mode to S4

I use a clean preset

Selected the midi ports in midi options for BCR2 and changed the id in BC manager - BC manager recognises the BCR2 and shows the firmware

Ableton live also sends and receives midi to the BCR2 via the midi cables

clayc
clayc's picture

i keep all the same settings on BCR2 and reconnect the USB cable and change the mode back to U1. enable the usb midi device and change the midi options for BCR2 - BCR2 is not recognised by BC manager

Mark van den Berg
Mark van den Berg's picture

From your tests it seems clear that the USB receiver of your second BCR is faulty.

This is exactly what was wrong with my first BCR. (Actually I only remember that the USB controller was faulty in only one direction; I can't remember which one.)
In my case the BCR was still in the warranty period, so I went back to the shop and after some deliberation they gave me a replacement unit.

So if you can complain to the shop or person you got yours from, you should do so.
Otherwise you'll have to work around this limitation, i.e. by not using the BCR's USB receiver.

I think you can forget about the unit being repaired (either by you or a "qualified" repair center). For one thing, if I remember correctly the USB controller is integrated in the chip that also houses the main CPU.

By the way, after all this is settled, you should really upgrade the firmware of your healthy BCR to 1.10.

Mark

Royce
Royce's picture

Hi. As Mark says the USB has been a common problem.

One possible solution is to open up the BCR and replace the power supply caps. They have known to go faulty and replacing them fixes the problem.

I tried this and it worked for a while, but then the unit failed again.

 I have noticed that there can be a spark when both the computer and the BCR are on and you connect the USB cable. USB is supposed to be hot swappable and the spark jumps from the grounded shield.

There may be need for some changes to the grounding and/or additional filtering on the USB driver chip.

I noticed that when I uninstall the USB drivers and reinstall them and then reboot the BCR it is OK for the rest of the day, sometimes for a couple of days. So every day I check and then reinstall if needed.

Many years ago I bought a new BCR and found the same problem, returned it for a replacement, twice! All three failed (the last one in the music store). They gave me their display unit which has been working ever since. So I thought it was just a bad batch. 

I am still working on this  as I seem to have acquired a few BCRs from other frustrated owners with this error.

I'll keep you posted.

All the best

Royce

Mark van den Berg
Mark van den Berg's picture

After the problems with my first BCR's faulty USB controller, I've always tried to avoid hot-plugging USB devices, in particular my (second) BCR and my BCF.
I'm pretty sure my first BCR was already faulty when I bought it, but I don't want to take unnecessary risks.

Around that time (2008) I read something that I interpreted as "it is inadvisable to hot-plug a BCF/BCR's USB cable." In my recollection this was in Behringer's documentation, but I can't remember where exactly, and I may have misunderstood anyway.
But it did stick with me, precisely because I found it very strange, since (as Royce mentioned) USB is supposed to be hot-pluggable, and why would the BCF/BCR deviate from the USB norm?
Still, I took the advice seriously:
At first I interpreted it as applying to both sides of the USB cable.
This led to a kind of paranoia: I got into the habit of always switching off a BCF/BCR and the computer before connecting or disconnecting the USB cable.
However, I have gradually started thinking that this piece of advice only warned against hot-plugging the USB cable at the side of the BCF/BCR, and recently I have indeed hot-plugged USB cables at the side of the computer without problems many times.
But I still apply caution to each and every USB device: I avoid hot-plugging as much as I can, and if I do need to hot-plug, I always first connect the cable to the USB device and then hot-plug into the computer's USB socket. This may all be total nonsense, but better safe than sorry...

Over the years I've encountered two very different scenarios in which connecting certain USB devices could hang a computer running Windows:

1. A flash drive (a.k.a. "USB memory stick"):
Hot-plugging a flash drive (of whatever brand) can hang a particular computer of mine (bought in 2011).
During the height of this problem I felt there was about a 50% chance this hanging would happen.
I had the impression that the chance of hanging increased if I inserted the flash drive at a wrong angle or speed, so that some of the contacts would short-circuit the computer's motherboard (or something).
Really horrible for my nerves...
Naturally I developed a strategy of first saving any open documents etc. before inserting a flash drive into this computer.

2. An external Seagate USB3 hard drive:
This drive has its own power cable, which ends in an adapter upon which sits the plug that goes into the wall socket.
(Actually I have several of these Seagate drives, all showing the same behavior, so if there's a fault in the Seagate drive, it's a generic one.)

Until about a year ago I always connected this drive as follows (with the computer already running):
1. Connect the power cable and the USB cable to the external HD.
2. Connect the USB cable to the computer.
3. Connect the power cable to the wall socket (hereby switching the HD on).
Step 3 has maybe a 25% chance of hanging my current main computer (bought in 2013).
Apparently, plugging in the external HD's power cable can give the computer a fatal voltage spike (or short-circuit?) via the already connected USB cable.

However, last year I discovered that the computer does not hang when I reverse steps 2 and 3 above:
1. Connect the power cable and the USB cable to the external HD.
2. Connect the power cable to the wall socket (hereby switching the HD on).
3. Connect the USB cable to the computer.
My interpretation is that this works so much better because the USB device, being already switched on, provides a stable voltage across the USB cable when the USB cable is getting connected to the computer.

Still it seems curious that in this case hot-plugging the USB cable is better than (semi-)cold-plugging it!

Why I'm bringing all this up:
Does any of you see any difference in USB malfunction depending on the exact connection procedure?
Between cold-plugging, hot-plugging at the BCR end, and hot-plugging at the computer's end?
Or is it simply a case of "once the caps are broken, they stay broken"?

clayc
clayc's picture

thats got me wondering about this because i did get it working once.  can the USB be fried and then work and then stop working?

I think ive just bought a dud this time. unfortunately it was second hand and bought from another State, so i cant return it.  Even now im running it with midi and its started doing that strange thing i mentioned previously where global setup wont work with the usual button presses.  By chance I worked out that i can get into global setup if i press EXIT-EDIT-STORE.  

EDIT-STORE does not work :(   It did work previously and then stopped working and then started working... etc...etc....Looks like time to buy a new one.

Mark van den Berg
Mark van den Berg's picture

can the USB be fried and then work and then stop working?

Royce is in a much better position than me to answer this, but this is indeed how I remember my first BCR:
Probably from day one USB communication would sometimes work, sometimes not. Sometimes I would lose communication mid-session. Sometimes restarting the BCR would help, sometimes not. Etc. etc.
It drove me completely nuts and went on for about a year, until I finally felt knowledgeable enough to go back to the shop.

Your problem with the special function buttons seems unrelated to the USB problem.
Perhaps one of the buttons involved is dodgy?
You may try BC Manager's "Test hardware" routine (accessible from the B-Controls window: MIDI -> Maintenance): this will allow you to test all your buttons and encoders (and their LEDs!) in an easy way. See section 10 of the manual for explanation.

But you're right: if there are indeed two different things wrong with the BCR, it may get a little desperate.
Then again, there are people who absolutely relish such challenges...
And if you collect enough faulty BCRs, you may be able to combine enough working parts into a working one. Bring out your soldering iron!

Royce
Royce's picture

Mark, I am supprised that you are getting communication failure mid session. All my BCs are go or not-go until a power cycle or cable change or change of USB mode and the driver unloads/reloads. Oh well, a new failure mode.

There are some self healing devices, and some devices will lock down for safety and only try again when there is a power cycle or the cause of the bad condition is removed, but I am unsure of how the USB is protected here. Mark is correct and USB is built into the CPU (OKI L671000: An ARM7TDMI CPU with full speed USB2 and UART).
If some switches have stopping working, the first check is the cable connecting the boards.

Can you get it to work if you press a bit harder or rock the switch a bit when you press? This second, and more likely failure mode is because tac switches do have a limited number of operation before they fail. This is true of all switches, but as there are so many of these tac switches used in a lot in synths you will hear about a lot of failures. They are relatively cheap and easy to replace (soldering required).

With all the problems you are having I would open it up (see Mark's pdf on how to do this)  and reseat the plugs between boards and push in the memory  IC into its socket.

https://mountainutilities.eu/system/files/download/How%20to%20open%20a%20B-Control.pdf

Here is a tear down with lots of pics for BCF2000 wich is close enough

http://www.slaveksamal.com/files/BCF2000.pdf

Mark van den Berg
Mark van den Berg's picture

I am supprised that you are getting communication failure mid session. All my BCs are go or not-go until a power cycle or cable change or change of USB mode and the driver unloads/reloads. Oh well, a new failure mode.

Since my problem was abt. 10 years ago, the details had become very vague in my mind, so after you'd written this I seriously started doubting my memory...
However, I've now found the email I sent to my BCR dealer back then, which contains the following, very specific run-down of my experiences (in particular note the underlined sentence):

The "standard" MIDI connections of this BCR have always worked perfectly, but the BCR's USB-based MIDI connection has never worked correctly. From the day I bought this BCR, the following has always happened:

With both the BCR and the computer switched off (and the BCR's USB driver already installed on the computer), I connect the USB cable, then start up the computer (running Windows XP+SP2), and switch on the BCR. Then, when I start a MIDI program from Windows (Sonar, Reason etc.), the USB-based MIDI input device (i.e. from the BCR to the program) either doesn't pass any data to the computer, or only for about a minute. If I then exit and restart the MIDI program, the program produces an error message like "Undefined external error", apparently because the MIDI input device from the BCR has become inaccessible altogether. (The actual message (if any) depends on the MIDI program (and the USB driver used), but in any case the source of this error message is the Windows MMSystem MIDI layer, responding to the MIDI program's attempt at connecting to the BCR's USB-based MIDI device.)

For months my "solution" to this problem was to then reinstall the BCR's USB driver, after which things might go well for a few hours or even the rest of the day. (But the next day the same ritual always occurred again.) Because this reinstallation of the USB driver "solved" the problem, I assumed that the cause of the problem was "somewhere" on the computer: messed-up USB drivers, a conflict in the operation system, etc.

However, a few months later I also bought a BCF2000, after which it gradually dawned on me that the problem really lies with the BCR itself, because I have never had any problem with the BCF's USB connection.

Two things about the underlined sentence are interesting:

  • My problem concerned USB communication from the BCR to the computer, which is the reverse direction of clayc's problem.
  • The clause "or only for about a minute" confirms the "mid-session" failures I mentioned.

In the same email I also described what happened when I connected my BCR to a friend's computer:

one time I connected the BCR to a USB-port on a friend's (relatively modern) notebook computer (running Windows XP Professional with SP2): his computer froze immediately (even before I got the chance to install any USB driver!), and only "thawed" when I switched the BCR off again. (This freezing also sometimes happens when I connect the BCR to my own computer; it may have become more frequent over time, but I'm not sure.)

So the behavior of my faulty BCR seemed to vary with the specific computer to which it got connected.

I have no idea what to make of all of this, beyond the obvious conclusion that USB communication to and from a BCR can be broken in various ways.

Which reminds me: in your earlier post you wrote

One possible solution is to open up the BCR and replace the power supply caps. They have known to go faulty and replacing them fixes the problem.

I tried this and it worked for a while, but then the unit failed again.

I find this rather strange: how can you have these failures so often, considering that most people's B-Controls never get broken in this way? Doesn't this suggest that the caps aren't the root cause of the problem? Unfortunately my knowledge of the BCR's hardware is sketchy at best, so I'm clutching at straws here.

Royce
Royce's picture

Hi Mark. You are right. I'd read a post on Yahoo about someone having success with this fix during a frustrating time where I just wanted to get some software going. I was using Mode U2 and every morning I had to do the USB dance to get things going. As they had had success I thought I would quickly pull the BC apart and replace the electro caps. I was aware that it seemed unlikely that that was the cause, but it was a quick job. It fixed it, but, of course it could have just a temporary heat fix for the chip or cct board, but I was happy that it caused the BC to start working again. I thought perhaps it will here as well.

As far as thoes lucky 'most people's BCRs' -  I have 4 BCRs and 1 BCF and, like you, I push them pretty hard. I am careful with them, but they are used a lot. This has been the only real problem I have had. Tac switches and encoders are fine on all units.  If there is a fault I will swap to an S mode and use a seperate Midi interface, but the built in 2 Midi ports is quite elegant solution for a lot of the editors I write.

If it a hardware fault, I think it is something to do with the difference in the ground potential on the USB earth. It is most definately the BC's USB input that fails.

More likely it is the USB driver as sometimes a reinstalation fixes it. Sometimes it needs a reboot post installation and sometimes it doesn't. Sometimes the BC need a power cycle and sometimes it doesn't.

Your failure on different computers would bring it back to hardware fault/design.

I have tried (multiple times) all the versions of the drivers on WinXP and Win7 64 and thoes that install all suffer the same fate. I have logged procedures and just when I think I get a repeatable error and sort out a fix that seems to work, it starts to go flakely or fails continiously.

This USB port/ driver seems to have many different failure modes and perhaps there is an interaction that make the failure  a combination of things.

I have just got a new oscilloscope that should be fast enough to take a peek. Just a bit time poor at the moment.

All the best

Royce

clayc
clayc's picture

thanks for all the help and input with this. Ive got the 2nd BCR working again just via midi.  I think its likely i will need to buy another one though but for the moment its working so im trying to get back to making music... ha ha....rather than solving tech issues!  :)