Experienced user - Editor won't receive or send with Win 10 version

8 posts / 0 new
Last post
twaw001
twaw001's picture
Experienced user - Editor won't receive or send with Win 10 version

Hi, I've been using the older version (2.99-2) for years on Win 7 machine, no problems.  I'm 1500 miles away from my Win 7 machine now and need to reconfigure some FCB buttons.  I've tried the last 2 versions on Win 10 several times but it just doesn't recgonize the FCB at all.  I'm starting by trying to receive data from the FCB, and have jsut a midi cable from FCB out to my interface midi in (midi cable, not usb).  Of course I've set my midi devices correctly, and leave midi thru as "none" (tried all options actually but no luck).  But I get absolutely nothing, not even any midi level or activity in the Editor.  But using my music apps, using the same midi cable, i can control everything correctly using the current configuaration I have in the FCB itself.   So there's something that's "blocking" data.

I'm on Win 10 Pro, interface is Quantum 2626 Firewire.  FWIW I know my quantum is good, it passes midi all day long to my other apps.

Any help is greatly aprpeciated!  I really don't want to go back to manually programming... not sure I even remember how! :)

Tom 

Mark van den Berg
Mark van den Berg's picture

I've been using the older version (2.99-2) for years on Win 7 machine, no problems.

To which editor are you referring?
The latest version of FCB1010 Manager is 2.2.1, so either you're mistaken about the version number you used before, or you're talking about a different editor.

twaw001
twaw001's picture

It's a much older version from mountain systems, it was called FCB 1010 MIDI Editor.  I think I first used it maybe 8 or 10 years ago. The new version that I'm having trouble with is what you referenced, 2.2.1.  tried it again yesterday, still no luck. Very strange.

GluBloB
GluBloB's picture

I guess that "Older version 2.99" must be this one.

http://host.mtnsys.com:81/faq-fcb/PCEditorBeta.htm

 

Mark van den Berg
Mark van den Berg's picture

It's a much older version from mountain systems, it was called FCB 1010 MIDI Editor.

Mountain Systems and Mountain Utilities are two unrelated companies.
So "FCB 1010 MIDI Editor" from Mountain Systems was made by somebody else, and has no connection to my "FCB1010 Manager".

The new version that I'm having trouble with is what you referenced, 2.2.1.  tried it again yesterday, still no luck. Very strange.

You should forget any expectations you have about FCB1010 Manager based on your experiences with the other editor, and approach it as the completely different editor that it is.

To make FCB1010 Manager communicate with your FCB1010, you must do two things:

  1. In the "MIDI devices" dialog box, you must enable the MIDI I/O devices to which your FCB1010 is connected. See section 5 of the FCB1010 Manager manual for details.
  2. In the "FCB1010 options" dialog box, you must tell FCB1010 Manager that these MIDI I/O devices are the ones to which your FCB1010 is connected. See "Options -> FCB1010" in section 6 of the manual.

Hope this helps,
   Mark.
 

 

twaw001
twaw001's picture

Hi thanks for the info.  Didn't know it was 2 different companies.  I tried your suggestion and am trying to receive existing sysex data on the FCB, but I get nothing, not even any signal on the midi meters.  I rechecked the midi settings as you said, but I already had that set correctly... tried re-selecting the correct ports, no change.  Tried different pass thru settings from None to my interface's out and in, no change.   It's strange because the FCB works and sends midi data just fine to my daw.   

Mark van den Berg
Mark van den Berg's picture

Tried different pass thru settings from None to my interface's out and in, no change.

If you're talking about FCB1010 Manager's "MIDI devices" dialog box: I suggest you leave all its "Thru input/output device" settings at "[None]". Making Thru connections probably does nothing to improve communication between your FCB1010 and FCB1010 Manager.

It's strange because the FCB works and sends midi data just fine to my daw.

At the very least you should be able to get Control Change messages etc. from the FCB to also show up in FCB1010 Manager's "MIDI input meters" window, and also in its "MIDI input messages" window (provided the Record button has been pressed).

Once that works, you can try to get the FCB's setup to FCB1010 Manager.
This is tricky, because the FCB1010 is very primitive and "moody": you need to follow the instructions given in the dialog box of FCB1010 Manager's "MIDI -> Receive" operation to the letter, or the operation will fail. And there are several pitfalls, as discussed under "MIDI -> Receive" in section 6 of the FCB1010 Manager manual.

Hope this helps,
   Mark.

twaw001
twaw001's picture

Thanks, Mark.  Yeah I'm familiar with how moody the FCB can be.  And I'd tried it many times with Midi Thru as "None", before I tired some other things.  I've gone thru the manual several times, re-checked everything... no change.  My DAW has midi monitoring and I've checked that too, and I'm getting good signal and the correct commands from the FCB.  I just ordered a couple new midid cables, which I needed anyway, and will try those.  The only other thing I can think of is, perhpas the software doesn't "like" my quantum 2626 interface, which is firewire.  But that interface has utitlities and everything is set correctly and recognized by the utility.  Or maybe there's some routing in my Windows 10 Pro that needs to happen.  Hmmm... I'd looked before but maybe I can dig a little deeper.  Maybe Exit the interface utilities?  IDK, I'm stumped.